summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAnton Leontiev2015-08-16 07:28:28 +0300
committerAnton Leontiev2015-08-16 07:28:28 +0300
commitacb06d7b853a91673e2f37e5c4838f55a6f5011a (patch)
tree482b9dda6adc85314e4319b5b88498d120d6b369 /PKGBUILD
parent35b26a19a8e37b7625a42e733f7a49180ad4f731 (diff)
downloadaur-acb06d7b853a91673e2f37e5c4838f55a6f5011a.tar.gz
Updated to v1.06
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 17 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7db873a32cbe..3738631b2729 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,41 @@
# CPAN Name : Tree::Binary
# Contributor: Anton Leontiev <bunder /at/ t-25.ru>
-# Generator : CPANPLUS::Dist::Arch 1.28
+# Generator : CPANPLUS::Dist::Arch 1.30
pkgname=perl-tree-binary
-pkgver=1.05
+pkgver=1.06
pkgrel=1
pkgdesc='Perl package for OO binary tree'
arch=('any')
-url='http://search.cpan.org/dist/Tree-Binary'
+url='https://metacpan.org/release/Tree-Binary'
license=('PerlArtistic' 'GPL')
depends=('perl')
checkdepends=('perl-test-exception')
-source=(http://search.cpan.org/CPAN/authors/id/R/RS/RSAVAGE/Tree-Binary-1.05.tgz)
+source=(http://search.cpan.org/CPAN/authors/id/R/RS/RSAVAGE/Tree-Binary-1.06.tgz)
options=(!emptydirs)
-md5sums=('4219fe4109544194e8fd6e5cb2e6b1f6')
+md5sums=('3e7d5dc33b14ddf218bac30861093e12')
+
+sanitize() {
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL="--skipdeps" MODULEBUILDRC=/dev/null
+}
build() {
- cd Tree-Binary-1.05
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ cd Tree-Binary-1.06
+ sanitize
+ /usr/bin/perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd Tree-Binary-1.05
+ cd Tree-Binary-1.06
+ sanitize
make test
}
package() {
- cd Tree-Binary-1.05
+ cd Tree-Binary-1.06
+ sanitize
make install DESTDIR="$pkgdir"
find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
}