summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAnton Leontiev2021-05-08 15:40:38 +0300
committerAnton Leontiev2021-05-08 15:40:38 +0300
commitdd36a358963d0a623779b7cf91350c18e9508a3b (patch)
treea93990d0ae91e646b7ab34cf668ef9dd41c67378 /PKGBUILD
parent11d511f8d8d546f99418e61fda29a06791602de2 (diff)
downloadaur-dd36a358963d0a623779b7cf91350c18e9508a3b.tar.gz
perl-tree-binary: Update to v1.09
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 18148a22261a..ae75a13e669e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,17 +3,17 @@
# Generator : CPANPLUS::Dist::Arch 1.32
pkgname=perl-tree-binary
-pkgver=1.08
-pkgrel=2
+pkgver=1.09
+pkgrel=1
pkgdesc='Perl package for OO binary tree'
arch=('any')
url='https://metacpan.org/release/Tree-Binary'
license=('PerlArtistic' 'GPL')
depends=('perl')
checkdepends=('perl-test-exception')
-source=(http://search.cpan.org/CPAN/authors/id/R/RS/RSAVAGE/Tree-Binary-1.08.tgz)
+source=(http://search.cpan.org/CPAN/authors/id/R/RS/RSAVAGE/Tree-Binary-1.09.tgz)
options=(!emptydirs)
-md5sums=('76ac414085486e9104f3ada832c231db')
+md5sums=('dbb7d2f9c9e8d8763e7b0d767f8c50b7')
sanitize() {
unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
@@ -21,20 +21,20 @@ sanitize() {
}
build() {
- cd Tree-Binary-1.08
+ cd Tree-Binary-1.09
sanitize
/usr/bin/perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd Tree-Binary-1.08
+ cd Tree-Binary-1.09
sanitize
make test
}
package() {
- cd Tree-Binary-1.08
+ cd Tree-Binary-1.09
sanitize
make install DESTDIR="$pkgdir"
find "$pkgdir" \( -name .packlist -o -name perllocal.pod \) -delete