summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorYardena Cohen2022-05-19 17:38:05 -0700
committerYardena Cohen2022-05-19 17:38:05 -0700
commit0d40035bfe2ade4c22a20e0a036739532a36b5c2 (patch)
tree6a8f0535205cef105bb24bae52e8384441051c15 /PKGBUILD
parent30c9e297330b6dd7170c18c3a1fb3fa27cdf87c2 (diff)
downloadaur-perl-true.tar.gz
bump 1.0.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 90f7690d3cc8..ee0fd1342c49 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,8 @@
cpaname=true
cpanauthor=CHOCOLATE
pkgname=perl-true
-pkgver=0.18
+pkgver=1.0.2
+pkgver_v=v${pkgver}
pkgrel=1
pkgdesc="Perl true CPAN module"
arch=('any')
@@ -16,22 +17,24 @@ depends=(
'perl-b-hooks-op-check'
'perl-devel-stacktrace'
'perl-extutils-depends'
+ 'perl-function-parameters'
+ 'perl-moo'
)
-source=("http://www.cpan.org/authors/id/${cpanauthor::1}/${cpanauthor::2}/${cpanauthor}/${cpaname}-${pkgver}.tar.gz")
-sha256sums=('ff3d041eb2a522ec6194d7a3888325e8a3ef2238ab51452f0b547696be0b4594')
+source=("https://www.cpan.org/authors/id/${cpanauthor::1}/${cpanauthor::2}/${cpanauthor}/${cpaname}-${pkgver_v}.tar.gz")
+sha256sums=('6a1ccd4008d4cc66ded4e2a1694b5b2a21d7655e276e1354160012ba2be2a284')
build() {
- cd "${srcdir}/${cpaname}-${pkgver}"
+ cd "${srcdir}/${cpaname}-${pkgver_v}"
perl Makefile.PL
make
}
check() {
- cd "${srcdir}/${cpaname}-${pkgver}"
+ cd "${srcdir}/${cpaname}-${pkgver_v}"
make test
}
package () {
- cd "${srcdir}/${cpaname}-${pkgver}"
+ cd "${srcdir}/${cpaname}-${pkgver_v}"
make install INSTALLDIRS=vendor DESTDIR="${pkgdir}"
}