summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSlithery2015-08-12 21:37:52 +0100
committerSlithery2015-08-12 21:37:52 +0100
commite7f2d41feac3930c4d7629467f75e4785e07c558 (patch)
tree6bfec96a1cfcec2216077d9f341c9ef5bb573f06 /PKGBUILD
downloadaur-e7f2d41feac3930c4d7629467f75e4785e07c558.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2bde20250ae5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Slithery <aur at slithery dot uk>
+# Contributor: Zack Buhman <zbuhman@linode.com>
+# Contributor: Phillip Smith <fukawi2@NO-SPAM.gmail.com>
+
+pkgname=perl-webservice-linode
+pkgver=0.19
+pkgrel=4
+pkgdesc="Perl Interface to the Linode.com API"
+url="http://search.cpan.org/~mikegrb/WebService-Linode/"
+license=('GPL1')
+arch=('any')
+depends=('perl-json' 'perl-lwp-protocol-https')
+makedepends=('git' 'perl-module-build-tiny')
+source=("$pkgname::git+https://github.com/mikegrb/WebService-Linode.git#tag=$pkgver")
+sha256sums=('SKIP')
+
+build() {
+ cd "$pkgname"
+ perl Build.PL
+ ./Build
+}
+
+package() {
+ cd "$pkgname"
+ ./Build install --destdir "$pkgdir" --installdirs vendor
+}