summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSimon Perry (Pezz)2019-06-25 11:08:26 +1000
committerSimon Perry (Pezz)2019-06-25 11:08:26 +1000
commit7634b14993e5eb5816873e918b92f26493fab0b5 (patch)
tree6a9633f2f674d1c85e547988b80f7ca73a5db9da /PKGBUILD
downloadaur-7634b14993e5eb5816873e918b92f26493fab0b5.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c08fd7130219
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Simon Perry <pezz [at] sanxion [dot] net>
+
+pkgname=perl-x11-wmctrl
+_relpkg=X11-WMCtrl
+pkgver=0.03
+pkgrel=1
+conflicts=('')
+replaces=('')
+pkgdesc="Perl wrapper for the wmctrl program"
+depends=('perl')
+license=('GPL' 'PerlArtistic')
+url="https://metacpan.org/pod/X11::WMCtrl"
+source=("$pkgname-$pkgver.tar.gz::https://cpan.metacpan.org/authors/id/G/GB/GBROWN/$_relpkg-$pkgver.tar.gz")
+options=('!emptydirs')
+arch=(any)
+sha256sums=('d71f935adcea0580fc6a74f35294fab547774cc7ceb0906365856ddb034f82a9')
+
+build()
+{
+ cd "$srcdir/$_relpkg-$pkgver"
+
+ perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+package()
+{
+ cd "$srcdir/$_relpkg-$pkgver"
+ make DESTDIR=${pkgdir} install
+
+ # Remove .packlist and perllocal.pod files.
+ find ${pkgdir} -name '.packlist' -delete
+ find ${pkgdir} -name 'perllocal.pod' -delete
+}
+# vim: ts=2 sw=2 et: