summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAnton Leontiev2017-12-17 11:21:48 +0300
committerAnton Leontiev2017-12-17 11:21:48 +0300
commit32fd15223efac3ef2cb1ecd026eeca48aa0e98d1 (patch)
tree6346204e4c84608031053e7543577c34027ee859 /PKGBUILD
parent7b45ac365200c51c0b9ab6c5f0fdc9d213818f12 (diff)
downloadaur-32fd15223efac3ef2cb1ecd026eeca48aa0e98d1.tar.gz
Update to v3.22
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 11 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 09403c2d36b5..65660920526c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,46 @@
# CPAN Name : XML::Compile::SOAP
-# Contributor: Anton Leontiev <bunder /at/ t-25.ru>
-# Generator : CPANPLUS::Dist::Arch 1.30
+# Contributor: Anton Leontiev <scileont /at/ gmail.com>
+# Generator : CPANPLUS::Dist::Arch 1.32
pkgname=perl-xml-compile-soap
-pkgver=3.10
+pkgver=3.22
pkgrel=1
pkgdesc='Perl package for SOAP implementations'
arch=('any')
url='https://metacpan.org/release/XML-Compile-SOAP'
license=('PerlArtistic' 'GPL')
depends=(
- 'perl-xml-compile>=1.50'
+ 'perl-xml-compile>=1.58'
'perl-xml-compile-tester>=0.90'
'perl-xml-compile-cache>=1.03'
'perl-log-report>=1.05'
'perl-libwww>=6.08'
+ 'perl-net-http>=6.16'
'perl-file-slurp-tiny')
-source=(http://search.cpan.org/CPAN/authors/id/M/MA/MARKOV/XML-Compile-SOAP-3.10.tar.gz)
+source=(http://search.cpan.org/CPAN/authors/id/M/MA/MARKOV/XML-Compile-SOAP-3.22.tar.gz)
options=(!emptydirs)
-md5sums=('92e9d952d432d3511a2bbccc7e3385df')
+md5sums=('d6ead08c6574c62a38bd969ea2475a74')
sanitize() {
unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
- export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL="--skipdeps" MODULEBUILDRC=/dev/null
+ export PERL_MM_USE_DEFAULT=1
}
build() {
- cd XML-Compile-SOAP-3.10
+ cd XML-Compile-SOAP-3.22
sanitize
/usr/bin/perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd XML-Compile-SOAP-3.10
+ cd XML-Compile-SOAP-3.22
sanitize
make test
}
package() {
- cd XML-Compile-SOAP-3.10
+ cd XML-Compile-SOAP-3.22
sanitize
make install DESTDIR="$pkgdir"
find "$pkgdir" -name .packlist -o -name perllocal.pod -delete