summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMarcell Meszaros2023-08-16 23:58:12 +0200
committerMarcell Meszaros2023-08-17 00:03:57 +0200
commit2d90450baddadb5a99193eb0112d605a8936a2cb (patch)
tree7e61cd74b3e66f5ea5ca2e806e8825f49f3453ff /PKGBUILD
parentd91afb08775ba2e4d65f8fdbe8f7bd1ebb88bd14 (diff)
downloadaur-2d90450baddadb5a99193eb0112d605a8936a2cb.tar.gz
1.0.1-1: update, fix, and make it a proper non-VCS package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 15 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cd234f1b478d..e2ae71caa10d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,35 @@
-# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+# Contributor: Marcell Meszaros < marcell.meszaros AT runbox.eu >
+# Contributor: Andy Weidenbaum <archbaum@gmail.com>
pkgname=perl6-digest
-pkgver=0.3.4
-pkgrel=4
+pkgver=1.0.1
+_gitref=f71ccf9525d5be5b552d9ee7e76f9a19e51afc02 # untagged version 1.0.1
+pkgrel=1
pkgdesc="Pure perl6 implementation of SHA-256 and RIPEMD-160 digests"
arch=('any')
-depends=('perl6')
+depends=('rakudo')
checkdepends=('perl')
makedepends=('git')
groups=('perl6')
url="https://github.com/grondilu/libdigest-perl6"
-license=('PerlArtistic')
-source=($pkgname-$pkgver::git+https://github.com/grondilu/libdigest-perl6)
-sha256sums=('SKIP')
+license=('Artistic2.0')
+source=("$pkgname::git+$url.git#commit=${_gitref}")
+b2sums=('SKIP')
check() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname"
- msg2 'Running tests...'
- PERL6LIB=lib prove -r -e perl6
+ echo 'Running tests...'
+ PERL6LIB=lib prove -v -e "raku -I." t/
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname"
- msg2 'Installing license...'
- install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
-
- msg2 'Installing documentation...'
+ echo 'Installing documentation...'
install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
- msg2 'Installing...'
+ echo 'Installing...'
export RAKUDO_LOG_PRECOMP=1
export RAKUDO_RERESOLVE_DEPENDENCIES=0
perl6-install-dist \