summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndy Weidenbaum2015-12-18 00:14:19 -0800
committerAndy Weidenbaum2015-12-18 00:14:19 -0800
commitdfc4fd1b734d9950fc8f403fd1b36824fe6b9a8f (patch)
tree30fdef611694643397377392cb0225d533167d49 /PKGBUILD
downloadaur-dfc4fd1b734d9950fc8f403fd1b36824fe6b9a8f.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ac9e497b800e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgname=perl6-html-parser
+pkgver=0.1
+pkgrel=1
+pkgdesc="Role for HTML parsing"
+arch=('any')
+depends=('rakudo' 'perl6-xml')
+checkdepends=('perl')
+makedepends=('git')
+groups=('perl6')
+url="https://github.com/tony-o/perl6-html-parser"
+license=('PerlArtistic')
+source=($pkgname-$pkgver::git+https://github.com/tony-o/perl6-html-parser)
+sha256sums=('SKIP')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ msg2 'Installing documentation...'
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
+
+ msg2 'Installing...'
+ mkdir -p "$pkgdir/usr/share/perl6/vendor/lib"
+ find lib -mindepth 1 -maxdepth 1 -exec \
+ cp -dpr --no-preserve=ownership '{}' "$pkgdir/usr/share/perl6/vendor/lib" \;
+}