summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndy Weidenbaum2016-02-23 06:41:40 -0800
committerAndy Weidenbaum2016-02-23 06:41:40 -0800
commited6dc97f5eb7821096c7f6bd779239ad280d7b6a (patch)
tree60e8af1cc49bb5c06b4bd1b6a2b5672514acf097 /PKGBUILD
parent068cb3943d7fcd4c4faef92fa886ba3c3bd656ad (diff)
downloadaur-ed6dc97f5eb7821096c7f6bd779239ad280d7b6a.tar.gz
simplify precomp grep, credit spider-mario
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 1 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 388f3d7a2c36..7075b4b20aa3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -37,11 +37,7 @@ package() {
alacryd install
msg2 'Removing redundant precomp file dependencies...'
- _precomp=($(pacman -Qg perl6 \
- | awk '{print $2}' \
- | xargs pacman -Ql \
- | awk '{print $2}' \
- | grep precomp))
+ _precomp=($(pacman -Qqg perl6 | pacman -Qql - | grep precomp))
for _pc in "${_precomp[@]}"; do
[[ -f "$pkgdir/$_pc" ]] && rm -f "$pkgdir/$_pc"
done