summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndy Weidenbaum2016-02-06 17:25:28 -0800
committerAndy Weidenbaum2016-02-06 17:25:28 -0800
commitdd052791a04c287caf5228afe8c2a8d0eeaaa589 (patch)
treecaa8c7aee59535d9810cb043398c5be05d4c706f /PKGBUILD
parente3a2d79a57662bdd118431931596b081ff0a0cce (diff)
downloadaur-dd052791a04c287caf5228afe8c2a8d0eeaaa589.tar.gz
increment pkgrel to 2; simplify native library build
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 3 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b046e4c38a7a..516b59f3ee6c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=perl6-linenoise
pkgver=0.1.0
-pkgrel=1
+pkgrel=2
pkgdesc="Bindings to linenoise"
arch=('i686' 'x86_64')
depends=('perl6' 'perl6-native-resources')
@@ -14,21 +14,12 @@ license=('MIT')
source=($pkgname-$pkgver::git+https://github.com/hoelzro/p6-linenoise)
sha256sums=('SKIP')
-prepare() {
- cd "$srcdir/$pkgname-$pkgver"
-
- msg2 'Preparing native library build script...'
- cat >> .alacryd-build-script.p6 << 'EOF'
-use Native::Resources::Build;
-make("$*CWD", "$*CWD/resources/lib", :libname<linenoise>);
-EOF
-}
-
build() {
cd "$srcdir/$pkgname-$pkgver"
msg2 'Building...'
- perl6 .alacryd-build-script.p6
+ perl6 -M Native::Resources::Build \
+ -e 'make("$*CWD", "$*CWD/resources/lib", :libname<linenoise>)'
}
check() {