summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndy Weidenbaum2016-11-03 20:49:02 -0700
committerAndy Weidenbaum2016-11-03 20:49:02 -0700
commit01b6d967c1c9781688ef98437ffadacadac24864 (patch)
tree7e078d955dbff938dd61ef2655c895cf7a0f75a5 /PKGBUILD
parent9ccccc4f543f18288d4cdd49f9b9827740101aad (diff)
downloadaur-01b6d967c1c9781688ef98437ffadacadac24864.tar.gz
increment pkgrel to 2; monkey typing fixed upstream
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 4 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c1e68c80a749..247b0bd752e0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=perl6-method-modifiers
pkgver=0.0.1
-pkgrel=1
+pkgrel=2
pkgdesc="Adds before, after and around functions to modify class methods similar to p5 Moose"
arch=('any')
depends=('perl6')
@@ -14,14 +14,6 @@ license=('PerlArtistic')
source=($pkgname-$pkgver::git+https://github.com/supernovus/perl6-method-modifiers)
sha256sums=('SKIP')
-prepare() {
- cd "$srcdir/$pkgname-$pkgver"
-
- msg2 'Fixing monkey typing...'
- sed -i 's/MONKEY_TYPING/MONKEY-TYPING/' lib/Method/Modifiers/Augment.pm6
- sed -i 's/skip_rest/skip-rest/' t/02-augment.t
-}
-
check() {
cd "$srcdir/$pkgname-$pkgver"
@@ -49,6 +41,7 @@ package() {
msg2 'Cleaning up pkgdir...'
rm -f "$pkgdir/usr/share/perl6/vendor/version"
- find "$pkgdir" -type f -name "*.lock" -exec rm '{}' \;
- find "$pkgdir" -type f -print0 | xargs -0 sed -i "s,$pkgdir,,g"
+ find "$pkgdir" -type f -name "*.lock" -exec rm '{}' +
+ find "$pkgdir" -type f -print0 -exec \
+ sed -i -e "s,$pkgdir,,g" -e "s,$srcdir,,g" '{}' +
}