summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndy Weidenbaum2016-05-30 13:41:02 -0700
committerAndy Weidenbaum2016-05-30 13:41:02 -0700
commit26943e4c84a62fc8e35bc4f1cf39ece5b930eb01 (patch)
tree084170ced173d33091e423390fe1426124caab10 /PKGBUILD
downloadaur-26943e4c84a62fc8e35bc4f1cf39ece5b930eb01.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1892ef353afd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+# Contributor: Jack O'Connor <oconnor663@gmail.com>
+
+pkgname=peru
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="a tool for including other people's code in your projects"
+arch=('any')
+depends=('git' 'python' 'python-yaml' 'python-docopt')
+makedepends=('python-setuptools')
+optdepends=('mercurial: fetching from hg repos'
+ 'subversion: fetching from svn repos')
+url="https://github.com/buildinspace/peru"
+license=('MIT')
+source=($pkgname-$pkgver.tar.gz::https://codeload.github.com/buildinspace/$pkgname/tar.gz/$pkgver)
+sha256sums=('386936ce853ed4d9d9b801d1c7d05295e54ceafebbb86fb89e78e27f504f6045')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ msg2 'Building...'
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ msg2 'Installing license...'
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+
+ msg2 'Installing documentation...'
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
+ cp -dpr --no-preserve=ownership docs/* "$pkgdir/usr/share/doc/$pkgname"
+
+ msg2 'Installing...'
+ python setup.py install --root="$pkgdir" --optimize=1
+}