summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartin Diehl2022-02-06 11:58:50 +0100
committerMartin Diehl2022-02-06 11:58:50 +0100
commit48d7daf27bfc8e39cc52efa0f90723c3cf870855 (patch)
tree7e39918c6a848fe4bc626143c07de5d00cb87d1d /PKGBUILD
parent30eb914a54738c9fee7295f82489dedae369e7e4 (diff)
downloadaur-48d7daf27bfc8e39cc52efa0f90723c3cf870855.tar.gz
PETSc is for number crunching
enabled machine-specific optimization
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fc6f4edc1fd3..dcb11865d95a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Lucas H. Gabrielli <heitzmann at gmail dot com>
pkgname=petsc
pkgver=3.16.4
-pkgrel=1
+pkgrel=2
_config=linux-c-opt
# if --with-debugging=yes is set then PETSC_ARCH is automatically set to
#"linux-c-debug" for some things, so the _config should be changed too
@@ -47,15 +47,16 @@ build() {
export PETSC_ARCH=${_petsc_arch}
export PETSC_DIR=${_build_dir}
+ OPTFLAGS='-O3 -march=native'
CONFOPTS="--with-shared-libraries=1 \
--with-petsc4py=1 \
--with-mpi-f90module-visibility=0 \
- --COPTFLAGS=-O3 --CXXOPTFLAGS=-O3 --FOPTFLAGS=-O3 \
--with-cc=$(which mpicc) --with-cxx=$(which mpicxx) --with-fc=$(which mpifort) \
$(sh ${srcdir}/test_optdepends.sh)"
echo ${CONFOPTS}
- python ./configure --prefix=${_install_dir} ${CONFOPTS}
+ python ./configure --prefix=${_install_dir} ${CONFOPTS} \
+ --COPTFLAGS=${OPTFLAGS} --CXXOPTFLAGS=${OPTFLAGS} --FOPTFLAGS=${OPTFLAGS}
make ${MAKEFLAGS} all
make DESTDIR=${srcdir}/tmp install