summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartin Diehl2020-06-02 09:35:53 +0200
committerMartin Diehl2020-06-02 09:35:53 +0200
commit58925dab79635de7f9e10eb3fb779be72c1e8b69 (patch)
tree395d164ab1fde5e6eff90baa31449fb3037aa379 /PKGBUILD
parent3f56d9246a780cacb7d2a6ad275f8d9394ef4c0d (diff)
downloadaur-58925dab79635de7f9e10eb3fb779be72c1e8b69.tar.gz
include fix fo DSTabulation in Fortran
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3ca6ee08e11b..0cc96e46d5fe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -31,13 +31,20 @@ optdepends=('trilinos: support for trilinos'
)
install=petsc.install
source=(http://ftp.mcs.anl.gov/pub/petsc/release-snapshots/${pkgname}-lite-${pkgver/_/-}.tar.gz
- test_optdepends.sh)
+ test_optdepends.sh
+ DSTabulation-Fortran-fix.patch)
sha256sums=('74a895e44e2ff1146838aaccb7613e7626d99e0eed64ca032c87c72d084efac3'
- '207f3c8107698f572f4075422bd069859c6a69b6bf92183d977dc802da323e18')
+ '207f3c8107698f572f4075422bd069859c6a69b6bf92183d977dc802da323e18'
+ '6907950866797d2a6058de8bc4d4369aa175c4cde92cb533b5b1e291db23edcf')
_install_dir=/opt/petsc/${_config}
_petsc_arch="arch-${_config}"
+prepare() {
+ cd "$pkgname-$pkgver"
+ patch --forward --strip=1 --input="${srcdir}/DSTabulation-Fortran-fix.patch"
+}
+
build() {
_build_dir="${srcdir}/${pkgname}-${pkgver/_/-}"