summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartin Diehl2021-09-23 10:43:11 +0200
committerMartin Diehl2021-09-23 10:44:35 +0200
commit9726624e4f0d83f22d59a4c33e6fc6b8c3771957 (patch)
treea67e701c9630919e0756dd6066389bad9bd3ee57 /PKGBUILD
parent6dd3bcd029635eb7190d6d3da7ea980b9a5b7ec6 (diff)
downloadaur-9726624e4f0d83f22d59a4c33e6fc6b8c3771957.tar.gz
make build in clean CHROOT possible
thanks to eDgar for the fix that does not require sudo
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8e6031a1b321..0c0dc25bb590 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Lucas H. Gabrielli <heitzmann at gmail dot com>
pkgname=petsc
pkgver=3.15.4
-pkgrel=3
+pkgrel=4
_config=linux-c-opt
# if --with-debugging=yes is set then PETSC_ARCH is automatically set to
#"linux-c-debug" for some things, so the _config should be changed too
@@ -32,13 +32,20 @@ optdepends=('trilinos: support for trilinos'
)
install=petsc.install
source=(http://ftp.mcs.anl.gov/pub/petsc/release-snapshots/${pkgname}-${pkgver}.tar.gz
- test_optdepends.sh)
+ test_optdepends.sh
+ petsc4py_nosudo.patch)
sha256sums=('1e62fb0859a12891022765d1e24660cfcd704291c58667082d81a0618d6b0047'
- 'f67901cec213c346481b6c9a56080dee9ee00a3852e46da9f35e933a11870623')
+ 'f67901cec213c346481b6c9a56080dee9ee00a3852e46da9f35e933a11870623'
+ 'df9d1ec9bd515fe17e25a6f98df8a913759cb0af21684c9aa454ad9e0a3a77bf')
_install_dir=/opt/petsc/${_config}
_petsc_arch=arch-${_config}
+prepare() {
+ cd ${pkgname}-${pkgver}
+ patch --forward --strip=1 --input=${srcdir}/petsc4py_nosudo.patch
+}
+
build() {
_build_dir=${srcdir}/${pkgname}-${pkgver}
cd ${_build_dir}
@@ -57,7 +64,7 @@ build() {
python ./configure --prefix=${_install_dir} ${CONFOPTS}
make ${MAKEFLAGS} all
- make SUDO_USER=$USER DESTDIR=${srcdir}/tmp install
+ make DESTDIR=${srcdir}/tmp install
}
check() {