summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorThomas Weißschuh2013-10-12 12:21:32 +0000
committerThomas Weißschuh2013-10-12 12:21:32 +0000
commitd81da6fd645ddb96b3cbb6c69ccb3dea9f324377 (patch)
tree17b4107df728f995149845b389e200bef749359d /PKGBUILD
downloadaur-pg_view-git.tar.gz
add pg_view-git
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d3eed1979784
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Thomas Weißschuh <thomas t-8ch de>
+
+pkgname='pg_view-git'
+pkgver=20130825
+pkgrel=1
+pkgdesc='postgreSQL Activity View Utility'
+url='https://github.com/zalando/pg_view'
+source=('git+https://github.com/zalando/pg_view.git')
+arch=('any')
+license=('Apache')
+depends=('python2-psycopg2')
+sha256sums=('SKIP')
+
+build() {
+ cd "${srcdir}/pg_view/"
+ sed -i '1s/python$/python2/' pg_view.py
+}
+
+package() {
+ cd "${srcdir}/pg_view/"
+ # install -D "${pkgdir}/usr/bin"
+ install -D -m755 pg_view.py "${pkgdir}/usr/bin/pg_view"
+}
+
+pkgver() {
+ date '+%Y%m%d'
+}