summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authora8212022-01-13 09:55:59 +0100
committera8212022-01-13 09:59:06 +0100
commit52dec9cb554ab99a19b2427b0ea2c747b339e335 (patch)
tree63f8794ab78d76996966856ceb580201f6f41b71 /PKGBUILD
parent1be62816193c512b970610ccdad70777d88817e0 (diff)
downloadaur-52dec9cb554ab99a19b2427b0ea2c747b339e335.tar.gz
Version 3.3.0 - revised
This version removes the pinned pygments version to allow system updates (and `pgcli` won't fail for the wrong reasons).
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index afb6897221aa..df7e860060b5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: Sven-Hendrik Haase <sh@lutzhaase.com>
pkgname=pgcli
-pkgver=3.2.0
-pkgrel=3
+pkgver=3.3.0
+pkgrel=2
pkgdesc="a command line interface for Postgres with auto-completion and syntax highlighting"
url="http://pgcli.com/"
arch=(any)
@@ -14,7 +14,12 @@ depends=('python-sqlparse' 'python-psycopg2' 'python-click' 'python-prompt_toolk
'python-keyring' 'python-pygments' 'python-pendulum')
makedepends=('python-setuptools')
source=($pkgname-$pkgver.tar.gz::https://github.com/dbcli/pgcli/archive/v$pkgver.tar.gz)
-sha256sums=('9ae5278853865bcec9ec7589773936c516512ae446514746658121a69915cbcf')
+sha256sums=('e6fefd9f77a060d5c2de30769022172f75df9cffd94b9d0593ed876ec3600e99')
+
+prepare() {
+ # remove pinned pygment version
+ sed -i 's/,<=2.11.1//' "pgcli-${pkgver}/setup.py"
+}
package() {
cd "pgcli-${pkgver}"