summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authora8212021-11-06 17:07:03 +0100
committera8212021-11-06 17:07:03 +0100
commit95325b0216515ef82a8d8012d456b079d18cded4 (patch)
treef3f21dc05ee70f453630d25f367e025445519587 /PKGBUILD
parent23b23d5ff97235de3055c3f5ca2a44191bcc8356 (diff)
downloadaur-95325b0216515ef82a8d8012d456b079d18cded4.tar.gz
Version 3.2.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 11 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b67b330235bd..8cc566e5dbc5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,24 @@
-# Maintainer: asm0dey <pavel.finkelshtein+AUR@gmail.com>
+# Maintainer: a821
+# Contributor: asm0dey <pavel.finkelshtein+AUR@gmail.com>
# Contributor: Sven-Hendrik Haase <sh@lutzhaase.com>
pkgname=pgcli
-pkgver=3.1.0
+pkgver=3.2.0
pkgrel=1
pkgdesc="a command line interface for Postgres with auto-completion and syntax highlighting"
url="http://pgcli.com/"
arch=(any)
license=('BSD')
-depends=('python' 'python-sqlparse>=0.3.0' 'python-psycopg2' 'python-click>=4.1' 'python-prompt_toolkit' 'python-humanize>=0.5.1' 'python-configobj>=5.0.6' 'python-pgspecial>=1.11.8' 'python-setproctitle>=1.1.9' 'python-cli_helpers>=1.2.0' 'python-keyring' 'python-dbus' 'python-pygments' 'python-pendulum')
-makedepends=('python-distribute')
-source=($pkgname-$pkgver.zip::https://github.com/dbcli/pgcli/archive/v$pkgver.zip)
+depends=('python-sqlparse' 'python-psycopg2' 'python-click' 'python-prompt_toolkit'
+ 'python-configobj' 'python-pgspecial' 'python-setproctitle' 'python-cli_helpers'
+ 'python-keyring' 'python-pygments' 'python-pendulum')
+makedepends=('python-setuptools')
+source=($pkgname-$pkgver.tar.gz::https://github.com/dbcli/pgcli/archive/v$pkgver.tar.gz)
provides=('pgcli')
-conflicts=('pgcli-git')
-md5sums=('2ce0bab01467c213555756c932b904a5')
+sha256sums=('9ae5278853865bcec9ec7589773936c516512ae446514746658121a69915cbcf')
package() {
- cd "$srcdir/pgcli-${pkgver}"
-# sed -i -e "s/prompt_toolkit>=2.0.6,<3.0.0/prompt_toolkit>=2.0.6/g" setup.py
-# sed -i -e "s/sqlparse >=0.3.0,<0.4/sqlparse >= 0.3.0,<0.5/g" setup.py
+ cd "pgcli-${pkgver}"
python setup.py install --root="$pkgdir/" --optimize=1
- mkdir -p "$pkgdir/usr/share/licenses/$pkgname"
- cp LICENSE.txt "$_/LICENSE"
+ install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}