summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorfzerorubigd2016-03-16 19:44:09 +0330
committerfzerorubigd2016-03-16 19:44:09 +0330
commitb9da632a5ba7a63465a848845c47fa80ec5a8415 (patch)
tree5cdf54e02e872881e2c71c37c0ebf2124c2ef15f /PKGBUILD
downloadaur-b9da632a5ba7a63465a848845c47fa80ec5a8415.tar.gz
initial port from the git version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..85fdd2696119
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: fzerorubigd <fzero@rubi.gd>
+# Contributor: Sven-Hendrik Haase <sh@lutzhaase.com>
+
+pkgname=pgcli
+pkgver=0.20.1
+pkgrel=1
+pkgdesc="a command line interface for Postgres with auto-completion and syntax highlighting"
+url="http://pgcli.com/"
+arch=(any)
+license=('BSD')
+depends=('python' 'python-sqlparse' 'python-psycopg2' 'python-click' 'python-prompt_toolkit' 'python-humanize' 'python-configobj' 'python-pgspecial' )
+makedepends=('python-distribute')
+source=($pkgname-$pkgver.zip::https://github.com/dbcli/pgcli/archive/v0.20.1.zip)
+provides=('pgcli')
+conflicts=('pgcli-git')
+
+package() {
+ cd $srcdir/pgcli
+ python setup.py install --root=$pkgdir/ --optimize=1
+ echo "#!/usr/bin/bash" > $pkgdir/usr/bin/pgcli
+ echo "python -c 'import pgcli.main; pgcli.main.cli()' \"\$@\"" >> $pkgdir/usr/bin/pgcli
+}
+md5sums=('a2a8823993b472f0fae2a555229b6aca')