summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorfahrenheit2018-04-08 18:26:51 +0100
committerfahrenheit2018-04-08 18:26:51 +0100
commit94e7c4e5d6cd6aa9d907db7451a9a7ee6f3b51b6 (patch)
treeb9c8b6bf624abe0c73949b4751e5d8b2481f64af /PKGBUILD
downloadaur-94e7c4e5d6cd6aa9d907db7451a9a7ee6f3b51b6.tar.gz
Added version 1.1.5 of PGSphere
Signed-off-by: fahrenheit <alka.setzer@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..154d13a2ba4a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# $Id$
+# Maintainer: Miguel Gomes <alka.setzer@gmail.com>
+
+pkgname=pgsphere
+pkgver=1.1.5
+pkgrel=1
+pkgdesc="Provides spherical data types, functions, and operators for PostgreSQL"
+arch=('x86_64')
+url="http://pgfoundry.org/projects/pgsphere/"
+license=('GPL')
+makedepends=('git')
+depends=('postgresql' )
+options=('!makeflags')
+source=(pgsphere::git://github.com/akorotkov/pgsphere.git)
+sha256sums=('SKIP')
+
+prepare() {
+ cd pgsphere
+}
+
+build() {
+ cd pgsphere
+ make USE_PGXS=1 PG_CONFIG=/usr/bin/pg_config
+}
+
+package() {
+ cd pgsphere
+ make DESTDIR="${pkgdir}" USE_PGXS=1 PG_CONFIG=/usr/bin/pg_config install
+} \ No newline at end of file