summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSaulius Lukauskas2015-08-05 11:47:23 +0100
committerSaulius Lukauskas2015-08-05 11:47:23 +0100
commit1dc6032a09421540fb911b579f7951b8941076f1 (patch)
tree5cd52c2de0abb31999f0c494e9a7e2f41bb7e8f4 /PKGBUILD
downloadaur-1dc6032a09421540fb911b579f7951b8941076f1.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9f818d459981
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Contributor: Sauliusl <luksaulius at gmail>
+pkgname=phantompeakqualtools
+pkgver=1.1
+pkgrel=1
+pkgdesc="Computes quick but highly informative enrichment and quality measures for ChIP-seq/DNase-seq/FAIRE-seq/MNase-seq data. It can also be used to obtain robust estimates of the predominant fragment length or characteristic tag shift values in these assays."
+arch=('i686' 'x86_64')
+url="https://code.google.com/p/phantompeakqualtools/"
+license=('MIT')
+depends=('r' 'r-catools' 'r-snow' 'samtools' 'boost' 'boost-libs')
+source=("https://phantompeakqualtools.googlecode.com/files/ccQualityControl.v.${pkgver}.tar.gz")
+md5sums=('66cfe40711edb914cd0fd69778a54e37')
+
+package() {
+
+ cd $srcdir/phantompeakqualtools
+ install -d $pkgdir/usr/lib/R/library
+
+ R CMD INSTALL -l $pkgdir/usr/lib/R/library spp_1.10.1.tar.gz
+
+ install -d $pkgdir/usr/share/${pkgname}/
+ install -Dm0644 run_spp.R $pkgdir/usr/share/${pkgname}/
+ install -Dm0644 run_spp_nodups.R $pkgdir/usr/share/${pkgname}/
+
+ echo "#!/bin/bash" > run_spp.sh
+ echo 'Rscript /usr/share/phantompeakqualtools/run_spp.R "$@"' >> run_spp.sh
+
+ echo "#!/bin/bash" > run_spp_nodups.sh
+ echo 'Rscript /usr/share/phantompeakqualtools/run_spp_nodups.R "$@"' >> run_spp_nodups.sh
+
+ install -d $pkgdir/usr/bin/
+ install -Dm0755 run_spp.sh $pkgdir/usr/bin/run_spp
+ install -Dm0755 run_spp_nodups.sh $pkgdir/usr/bin/run_spp_nodups
+
+
+}