summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSebastian Krzyszkowiak2019-09-23 19:27:56 +0200
committerSebastian Krzyszkowiak2019-09-23 19:28:38 +0200
commit00bc81049880e6852053b5775f774cf1fe01b147 (patch)
tree9ed539dc7e3a59b38877e8f7d28074bf1ba31727 /PKGBUILD
parentb2cd43adde7a5a48cef852f4b919d6b529df5b2d (diff)
downloadaur-00bc81049880e6852053b5775f774cf1fe01b147.tar.gz
use the system copy of wlroots
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 3 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ac5cec5dc884..b87454b5a143 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,13 @@
# Maintainer: Sebastian Krzyszkowiak <dos@dosowisko.net>
pkgname=phoc-git
-pkgver=r118.d8375ab
+pkgver=r161.d81666f
pkgrel=1
pkgdesc="Wayland compositor for phones"
url="https://source.puri.sm/Librem5/phoc"
license=("GPL3")
arch=(i686 x86_64 armv6h armv7h)
-depends=('libcap' 'systemd' 'wayland' 'opengl-driver' 'libxcb'
- 'xcb-util-errors' 'xcb-util-image' 'xcb-util-wm' 'pixman'
- 'libinput' 'libxkbcommon' 'libpng' 'ffmpeg' 'glib2')
+depends=('glib2' 'wlroots')
makedepends=('meson' 'ninja' 'git' 'wayland-protocols' 'ctags')
provides=(phoc)
conflicts=(phoc)
@@ -22,7 +20,7 @@ pkgver() {
}
build() {
- arch-meson phoc build
+ arch-meson phoc build -Dembed-wlroots=disabled -Ddefault_library=shared
ninja -C build
}