summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLukáš Jirkovský2016-05-25 23:13:53 +0200
committerLukáš Jirkovský2016-05-25 23:13:53 +0200
commite8f9e724fa0229cf55199550b67367008b7beae5 (patch)
treede4243c7cf7fa98fb54b7a9040a9cc96ffd3218d /PKGBUILD
parenta3c00a598c2c29e1ac8d3cb7665661d62fe9c0aa (diff)
downloadaur-e8f9e724fa0229cf55199550b67367008b7beae5.tar.gz
update source URL, compilation fixes, various small improvements
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cecf40fa4231..7818c59ad41c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Lukas Jirkovsky <l.jirkovsky AT gmail.com>
pkgname=photivo-hg
-pkgver=1113.66a8c1082d88
+pkgver=1117.5d7d1cc4ef4d
pkgrel=1
pkgdesc="Free and open source photo processor"
arch=('i686' 'x86_64')
@@ -11,8 +11,7 @@ optdepends=('gimp: Gimp plugins' 'python2: Gimp to Photivo plugin')
makedepends=('mercurial' 'gimp')
provides=('photivo')
conflicts=('photivo')
-install=photivo.install
-source=('hg+https://code.google.com/p/photivo/')
+source=('hg+https://bitbucket.org/Photivo/photivo')
md5sums=('SKIP')
pkgver() {
@@ -23,21 +22,24 @@ pkgver() {
prepare() {
cd "$srcdir/photivo"
- # fix the "Gimp to Photivo" plugin
- sed -i -e 's|\x0D$||' -e 's|#!.*|#!/usr/bin/python2|' "mm extern photivo.py"
+ # pull build fixes
+ hg pull -u https://stativ@bitbucket.org/stativ/photivo
}
build() {
cd "$srcdir/photivo"
export INCLUDEPATHS="/usr/include/lensfun"
- qmake-qt4 PREFIX=/usr CONFIG+=WithGimp
+ qmake-qt4 PREFIX=/usr CONFIG-=debug CONFIG+=WithGimp
make
}
package() {
cd "$srcdir/photivo"
+ # do not install local the shortcut to the home
+ sed '/^install:/ s|install_shortcut2 ||' -i Makefile
+
make INSTALL_ROOT="$pkgdir" install
rm -rf "$pkgdir"/home