summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarlos Henrique Merces Moreira2016-06-13 15:52:42 -0300
committerCarlos Henrique Merces Moreira2016-06-13 15:52:42 -0300
commit14c322a7c801e852f4c1770e1c46155a31626935 (patch)
tree75bf6cdd33786a5814a997fdd420ca76d514b2e9 /PKGBUILD
parent4d81a796141b49b39bb077e6dfb0d404bf7bc777 (diff)
downloadaur-14c322a7c801e852f4c1770e1c46155a31626935.tar.gz
Add python2-pillow and mencoder as dependencies, remove python2-pip from
dependencies and not use it anymore to build the package, instead, use just python to build and install the package. Remove photofilmstrip.install.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 17 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ad61e760b01d..9c4dde97ba3d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,28 @@
# Maintainer: Carlos Henrique Merces Moreira "chmercesmoreira" <ch.mercesmoreira@gmail.com>
pkgname=photofilmstrip
pkgver=2.1.0
-pkgrel=2
+pkgrel=3
pkgdesc="Create video clips from photos"
arch=('i686' 'x86_64')
url="http://www.photofilmstrip.org/1-0-Home.html"
license=('GPL2')
-depends=('python2-pip' 'wxpython')
+depends=('wxpython' 'python2-pillow' 'mencoder')
source=("http://liquidtelecom.dl.sourceforge.net/project/photostoryx/$pkgname/$pkgver/$pkgname-$pkgver.tar.gz")
-noextract=("${source[@]%%::*}")
md5sums=('0488f7b9cf8f99cff5b161c1911d9588')
-install="${pkgname}.install"
-package (){
- sudo pip2 install image
- sudo pip2 install $pkgname-$pkgver.tar.gz
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python2.7 setup.py build
}
+
+package () {
+ cd "$srcdir/$pkgname-$pkgver"
+ python2.7 setup.py install --root="$pkgdir" --optimize=1
+
+ chmod 644 $pkgdir/usr/share/applications/photofilmstrip.desktop
+
+ for size in 32x32 48x48 64x64 192x192
+ do
+ chmod 644 $pkgdir/usr/share/icons/hicolor/$size/apps/photofilmstrip.png
+ done
+} \ No newline at end of file