summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoseph Carta2023-09-27 19:28:58 -0400
committerJoseph Carta2023-09-27 19:28:58 -0400
commitf0f833dcd6f1f6394e31a79d51d28b021e8077aa (patch)
treefa482448d95a5091abef0f4fa54c1b8dce510d52 /PKGBUILD
parent231947d7dbb8bcbb7166767c9884f19d3d7c128b (diff)
downloadaur-photofilmstrip-git.tar.gz
Added missing makedepend, modified versioning.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 02faafda4f0d..a834d7a5e8cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer: Joseph Carta <cartakid@gmail.com>
# Contributor: acxz <akashpatel2008 at yahoo dot com>
pkgname=photofilmstrip-git
-pkgver=r658.ed795e7
+pkgver=4.0.0a2.r116.g4780e9d
pkgrel=1
pkgdesc="Create video clips from photos"
-arch=('i686' 'x86_64')
+arch=('any')
url="http://www.photofilmstrip.org/en/"
license=('GPL2')
depends=('python' 'python-wxpython' 'python-pillow' 'gst-python'
@@ -14,6 +14,7 @@ optdepends=('gst-plugins-bad: additional rendering formats'
'gst-plugins-ugly: additional rendering formats'
'gst-libav: additional rendering formats'
'python-cairo: slideshow preview')
+makedepends=('git')
_pkgname=PFS
provides=('photofilmstrip')
conflicts=('photofilmstrip')
@@ -22,7 +23,7 @@ md5sums=("SKIP")
pkgver() {
cd "$_pkgname"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long --tags --abbrev=7 | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {