summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoralexdiaconescu2018-12-07 10:34:41 +0200
committeralexdiaconescu2018-12-07 10:34:41 +0200
commit99b33e881a15826ed270885995f0b9b3cece8a23 (patch)
tree5a9f7e63b8439bf7c6b03c0d49f6ab58cb541330 /PKGBUILD
parent92ce5da2280b90515ef810019716d8103e56d235 (diff)
downloadaur-99b33e881a15826ed270885995f0b9b3cece8a23.tar.gz
Update to r2461.3b63cfa7
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD6
1 files changed, 2 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7fd3f55e327c..e8516f3242fb 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Contributor: Darko82 <darko 82 (hat) gmail dotcom>
# Maintainer: Joermungand <joermungand at gmail dot com>
pkgname=photoflow-git
-pkgver=r2352.ee4b2f45
+pkgver=r2461.3b63cfa7
pkgrel=1
pkgdesc="Non-destructive, layer-based photo retouching including RAW image development"
arch=('i686' 'x86_64')
url="http://aferrero2707.github.io/PhotoFlow"
license=('GPL3')
-depends=('exiv2' 'vips>=8.5.1' 'gtkmm' 'pugixml' 'libjpeg-turbo')
+depends=('exiv2' 'vips-8.6.5' 'gtkmm' 'pugixml' 'libjpeg-turbo')
makedepends=('git' 'gobject-introspection' 'cmake')
provides=('photoflow')
conflicts=('photoflow')
@@ -18,12 +18,10 @@ md5sums=("SKIP")
pkgver() {
cd ${pkgname%-*}
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-# git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
cd ${srcdir}/${pkgname%-*}
- sed -i 's/-Werror//' src/external/rawspeed/CMakeLists.txt
mkdir -p build
cd build
cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DINSTALL_PREFIX=/usr -DBUNDLED_GEXIV2=OFF ..