summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVladimir Magyar2021-05-13 07:33:22 +0200
committerVladimir Magyar2021-05-13 07:33:22 +0200
commitab8677c367837507ccde64cab9c3f7b8862354d1 (patch)
treed32a34b95880ae531d0d0045007f4a1b9ad9caea /PKGBUILD
downloadaur-ab8677c367837507ccde64cab9c3f7b8862354d1.tar.gz
version 0.1.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f7639ecfe4b8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+pkgname=photon-rss
+_pkgname=photon
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Fast RSS reader as light as a photon"
+arch=("i686" "pentium4" "x86_64" "arm" "armv6h" "armv7h" "aarch64")
+url="https://gitlab.com/microo8/photon"
+license=("GPL3")
+makedepends=(
+ "go>=1.16"
+ "git"
+)
+optdepends=(
+ "youtube-dl: A command-line program to download videos from YouTube.com and a few more sites"
+ "mpv: a free, open source, and cross-platform media player"
+ "imv: Image viewer for Wayland and X11"
+)
+source=("${_pkgname}::git+https://gitlab.com/microo8/photon.git")
+sha256sums=("SKIP")
+
+prepare(){
+ cd "$_pkgname"
+ mkdir -p build/
+}
+
+build() {
+ cd "$_pkgname"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ go build -tags nox11 .
+}
+
+package() {
+ cd "$_pkgname"
+ install -Dm755 $_pkgname "$pkgdir"/usr/bin/photon
+}