summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorluspi2023-12-07 22:43:26 -0600
committerluspi2023-12-07 22:43:26 -0600
commit22d8d1b43c186d7d3a17936b2c362ff2fdd32b48 (patch)
treeef114d7a9f520d88f58ffe67453fc9e23b0780ce /PKGBUILD
parent05f9aa4bdd57ad2fca5ca60b762ac890cb6f46e7 (diff)
downloadaur-22d8d1b43c186d7d3a17936b2c362ff2fdd32b48.tar.gz
add patch to fix linker issue for exiv2
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f9b2f0d1a5a9..3fbef4ea9e38 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=photoqt
pkgver=3.4
-pkgrel=2
+pkgrel=3
pkgdesc="Fast and highly configurable image viewer with a simple and nice interface."
arch=('x86_64')
url="http://photoqt.org/"
@@ -15,8 +15,10 @@ depends=('exiv2' 'imagemagick' 'qt5-imageformats' 'qt5-multimedia' 'qt5-svg' 'qt
optdepends=('libqpsd-git: PSB/PSD support'
'xcftools: XCF support')
makedepends=('cmake' 'qt5-tools' 'extra-cmake-modules')
-source=(https://photoqt.org/downloads/source/$pkgname-$pkgver.tar.gz)
-sha256sums=('9157fdfb323daed10c992d0de2aacdebbdd3ff57e7a9f715de140f9cc5cc2dab')
+source=(https://photoqt.org/downloads/source/$pkgname-$pkgver.tar.gz
+ exiv2.patch)
+sha256sums=('9157fdfb323daed10c992d0de2aacdebbdd3ff57e7a9f715de140f9cc5cc2dab'
+ 'e482087979d3bc4303a84a7f2fef716baf3e013771b9a85ed0cd85d12dd5038f')
prepare() {
cd $srcdir/$pkgname-$pkgver
@@ -25,6 +27,8 @@ prepare() {
# the next line (where xxxx is the respective CMake option).
# to use GraphicsMagick instead of ImageMagick add: -DIMAGEMAGICK=OFF -DGRAPHICSMAGICK=ON
cmake . -DCMAKE_INSTALL_PREFIX=/usr -DFREEIMAGE=OFF -DDEVIL=OFF -DPOPPLER=OFF -DIMAGEMAGICK=ON -DGRAPHICSMAGICK=OFF -DLIBVIPS=OFF -DVIDEO_MPV=ON -DCHROMECAST=OFF -DRESVG=ON
+
+ patch -p0 < $srcdir/exiv2.patch
}