summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorluspi2018-05-28 15:16:41 +0200
committerluspi2018-05-28 15:16:41 +0200
commit6e8c75aa8f302ed2c89a374ceae0e3a2b5b40631 (patch)
treefa41d94661416ddf8908699cdb12495cc790091a /PKGBUILD
parentc65064a0ce430cd89c9d50e07ec6348ef8c5a0bf (diff)
downloadaur-6e8c75aa8f302ed2c89a374ceae0e3a2b5b40631.tar.gz
fix: Qt 5.11 removed qt5_use_modules() cmake function causes cmake to fail -> added patch to replace by target_link_libraries() cmake function
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6ebefb969015..5fb722245f3b 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,11 +13,16 @@ depends=('exiv2' 'graphicsmagick' 'qt5-imageformats' 'qt5-multimedia' 'qt5-svg'
optdepends=('libqpsd-git: PSB/PSD support'
'xcftools: XCF support')
makedepends=('cmake' 'qt5-tools' 'extra-cmake-modules')
-source=(http://photoqt.org/pkgs/$pkgname-$pkgver.tar.gz)
-md5sums=('cef43bab96392542a15aaae10b7b6aeb')
+source=(http://photoqt.org/pkgs/$pkgname-$pkgver.tar.gz
+ qt5usemodules.patch)
+md5sums=('cef43bab96392542a15aaae10b7b6aeb'
+ 'db9263e2ec6e85f50f4185765a4f633f')
prepare() {
cd $srcdir/$pkgname-$pkgver
+
+ # In Qt 5.11, qt5_use_modules() does not exist anymore and needs to be replaced by target_link_libraries()
+ patch < $srcdir/qt5usemodules.patch
# To build PhotoQt with less features, add -Dxxxx=OFF to
# the next line (where xxxx is the respective CMake option).
@@ -26,7 +31,7 @@ prepare() {
build() {
cd $srcdir/$pkgname-$pkgver
- make
+ make -j3
}
package() {