summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorluspi2018-05-15 16:50:27 +0200
committerluspi2018-05-15 16:50:27 +0200
commit79639837f5c399291e4d84eac142a309835f47b4 (patch)
treea37be4270e0100cd9332de287895ef460ccb3d04 /PKGBUILD
parent9e313ccd7f8748054b8275513306cf323c79f991 (diff)
downloadaur-79639837f5c399291e4d84eac142a309835f47b4.tar.gz
minor tweak (disabled freeimage and devil by default)
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 44e296b07901..b296305e0584 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,8 @@ pkgdesc="Fast and highly configurable image viewer with a simple and nice interf
arch=('x86_64')
url="http://photoqt.org/"
license=('GPL2')
-depends=('exiv2' 'graphicsmagick' 'qt5-imageformats' 'qt5-multimedia' 'qt5-svg' 'qt5-quickcontrols' 'libraw' 'qt5-graphicaleffects' 'hicolor-icon-theme' 'poppler-qt5' 'freeimage' 'devil-ilut' 'libarchive' 'kimageformats')
+depends=('exiv2' 'graphicsmagick' 'qt5-imageformats' 'qt5-multimedia' 'qt5-svg' 'qt5-quickcontrols' 'libraw' 'qt5-graphicaleffects' 'hicolor-icon-theme' 'poppler-qt5' 'libarchive' 'kimageformats')
+# 'freeimage' 'devil-ilut'
optdepends=('libqpsd-git: PSB/PSD support'
'xcftools: XCF support')
makedepends=('cmake' 'qt5-tools')
@@ -20,7 +21,7 @@ prepare() {
# To build PhotoQt with less features, add -Dxxxx=OFF to
# the next line (where xxxx is the respective CMake option).
- cmake . -DCMAKE_INSTALL_PREFIX=/usr
+ cmake . -DCMAKE_INSTALL_PREFIX=/usr -DFREEIMAGE=OFF -DDEVIL=OFF
}
build() {