summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorluspi2021-02-02 11:39:07 -0600
committerluspi2021-02-02 11:39:07 -0600
commitab974bec4b1d11c4424c524e6ef430e11c38a129 (patch)
tree1e2d283c6a422be39548fd716b54820b885d6635 /PKGBUILD
parent3756ee5fa4773013768cace21e3201d5b4789278 (diff)
downloadaur-ab974bec4b1d11c4424c524e6ef430e11c38a129.tar.gz
use graphicsmagick by default (possible build issues), apply two small patches published on photoqt.org
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD21
1 files changed, 14 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d6a8194e4326..f27cb1c7478e 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,27 +3,34 @@
pkgname=photoqt
pkgver=2.1
-pkgrel=1
+pkgrel=2
pkgdesc="Fast and highly configurable image viewer with a simple and nice interface."
arch=('x86_64')
url="http://photoqt.org/"
license=('GPL2')
-depends=('exiv2' 'imagemagick' 'qt5-imageformats' 'qt5-multimedia' 'qt5-svg' 'qt5-quickcontrols' 'libraw' 'qt5-graphicaleffects' 'hicolor-icon-theme' 'libarchive' 'kimageformats' 'pugixml')
+depends=('exiv2' 'graphicsmagick' 'qt5-imageformats' 'qt5-multimedia' 'qt5-svg' 'qt5-quickcontrols' 'libraw' 'qt5-graphicaleffects' 'hicolor-icon-theme' 'libarchive' 'kimageformats' 'pugixml')
# 'freeimage' 'devil-ilut' 'poppler-qt5'
-# to use GraphicsMagick instead of ImageMagick replace it in the depends array above
+# to use ImageMagick instead of GraphicsMagick replace it in the depends array above
optdepends=('libqpsd-git: PSB/PSD support'
'xcftools: XCF support')
makedepends=('cmake' 'qt5-tools' 'extra-cmake-modules')
-source=(http://photoqt.org/pkgs/$pkgname-$pkgver.tar.gz)
-sha256sums=('a334c73efb9a6be272b8e837a009e819d5672581273d56bb585a93595794d43a')
+source=(http://photoqt.org/pkgs/$pkgname-$pkgver.tar.gz
+ sorting-2.1.patch
+ dontadddir-2.1.patch)
+sha256sums=('a334c73efb9a6be272b8e837a009e819d5672581273d56bb585a93595794d43a'
+ '8c05d137674fead5b9026e9e2f25a8198c019313d54e84f813718e683edd1448'
+ 'd0676748a3db1398708947c3e638316c8862d958d1d6b54ae85cf8684b249878')
prepare() {
cd $srcdir/$pkgname-$pkgver
+ patch -p1 < ../sorting-2.1.patch
+ patch -p1 < ../dontadddir-2.1.patch
+
# To build PhotoQt with less features, add -Dxxxx=OFF to
# the next line (where xxxx is the respective CMake option).
- # to use GraphicsMagick instead of ImageMagick add: -DIMAGEMAGICK=OFF -DGRAPHICSMAGICK=ON
- cmake . -DCMAKE_INSTALL_PREFIX=/usr -DFREEIMAGE=OFF -DDEVIL=OFF -DPOPPLER=OFF
+ # to use ImageMagick instead of GraphicsMagick add: -DIMAGEMAGICK=ON -DGRAPHICSMAGICK=OFF
+ cmake . -DCMAKE_INSTALL_PREFIX=/usr -DFREEIMAGE=OFF -DDEVIL=OFF -DPOPPLER=OFF -DIMAGEMAGICK=OFF -DGRAPHICSMAGICK=ON
}