summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLukas Spies2015-07-28 11:22:39 -0230
committerLukas Spies2015-07-28 11:22:39 -0230
commitc111e9572f5eb8f913055bbe8699fe7e3d7f25a9 (patch)
tree7526a5b1b1f0e9607d530bc6d040f6a45fd2e68a /PKGBUILD
downloadaur-c111e9572f5eb8f913055bbe8699fe7e3d7f25a9.tar.gz
Update to 1.3
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..ac567a5bb3d6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: archtux <antonio dot arias99999 at gmail dot com>
+
+pkgname=photoqt
+pkgver=1.3
+pkgrel=1
+pkgdesc="Fast and highly configurable image viewer with a simple and nice interface."
+arch=('i686' 'x86_64')
+url="http://photoqt.org/"
+license=('GPL2')
+depends=('exiv2' 'graphicsmagick' 'qt5-imageformats' 'qt5-multimedia' 'qt5-svg' 'qt5-declarative')
+optdepends=('libqpsd-git: PSB/PSD support'
+ 'xcftools: XCF support')
+makedepends=('cmake' 'qt5-tools')
+install=$pkgname.install
+source=(http://photoqt.org/pkgs/$pkgname-$pkgver.tar.gz)
+md5sums=('9240f33d0c4e55316ce96b1c1ef25042')
+
+prepare() {
+ cd $srcdir/$pkgname-$pkgver
+
+ # If you want to build PhotoQt with less features(without exiv2 and graphicsmagick), add (-DEXIV2=OFF -DGM=OFF) to next line.
+ cmake . -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release
+}
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ make
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ make DESTDIR=$pkgdir install
+} \ No newline at end of file