summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorOfer Kashayov2015-12-11 11:29:48 +0200
committerOfer Kashayov2015-12-11 11:29:48 +0200
commitd1fc6198fa0e42df0252e8117b6c7c60b06a1f36 (patch)
treecfe7e5d20306cf2486fc198bbd5121335d5327c5 /PKGBUILD
parent5feed0bbb10b406ac1bed06a4ba7ae3a5d73fa1c (diff)
downloadaur-d1fc6198fa0e42df0252e8117b6c7c60b06a1f36.tar.gz
Update to 1.7.13
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b5550f9f4bc6..e252e087d853 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
pkgname=phototonic
-pkgver=1.7.1
+pkgver=1.7.13
pkgrel=1
+phototonic_commit=c1998178dfc49275c716250914ee1aac910ab908
pkgdesc="Image Viewer and Organizer"
arch=('i686' 'x86_64')
url="http://oferkv.github.io/phototonic/"
@@ -8,11 +9,11 @@ license=('GPL3')
depends=('qt5-base' 'exiv2' 'libxkbcommon-x11')
optdepends=('qt5-imageformats: TIFF and TGA support' 'qt5-svg: SVG support')
provides=('phototonic')
-source=("https://github.com/oferkv/phototonic/archive/c3737334746d0bae2369b23d982ade5a981dcdd7.tar.gz")
-md5sums=('e29e7dc3a0f5ee08b084c68501140d45')
+source=("https://github.com/oferkv/phototonic/archive/$phototonic_commit.tar.gz")
+md5sums=('6c65ca3cb26f575c3983bcde15246ada')
build() {
- cd "$srcdir/$pkgname-c3737334746d0bae2369b23d982ade5a981dcdd7"
+ cd "$srcdir/$pkgname-$phototonic_commit"
qmake-qt5 PREFIX="/usr" \
QMAKE_CFLAGS_RELEASE="$CPPFLAGS $CFLAGS" \
QMAKE_CXXFLAGS_RELEASE="$CPPFLAGS $CXXFLAGS" \
@@ -21,6 +22,6 @@ build() {
}
package() {
- cd "$srcdir/$pkgname-c3737334746d0bae2369b23d982ade5a981dcdd7"
+ cd "$srcdir/$pkgname-$phototonic_commit"
make INSTALL_ROOT="$pkgdir/" install
}