summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJames An2016-07-19 07:50:20 -0400
committerJames An2016-07-19 07:50:20 -0400
commitff8ee69dccf39ab4c5e95c1c6e715d5e1395f40c (patch)
treeece29917d8b1bd0b304161d4af9c9075e8b13e16 /PKGBUILD
parent0635c7baa36147d6d3437b8c1e55fab1272ff441 (diff)
downloadaur-ff8ee69dccf39ab4c5e95c1c6e715d5e1395f40c.tar.gz
Fixed pkgver() to output version in correct format.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 04a1b0a92498..897b353a277c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname="php-cairo-git"
_pkgname=${pkgname%-git}
__pkgname=${_pkgname#php-}
-pkgver=1.0.0_dev.r9.9662114
+pkgver=1.0.0_dev.r9.g9662114
pkgrel=1
pkgdesc="PHP Object Oriented interface to Cairo Graphics library."
arch=('any')
@@ -22,7 +22,7 @@ pkgver() {
set -o pipefail
release="$(grep VERSION src/php_cairo.h | cut -f2 -d\" | tr - _)"
hash="$(git blame src/php_cairo.h | grep VERSION | cut -f1 -d\ )"
- revision="$(git rev-list --count $hash..HEAD).$(git rev-parse --short HEAD)"
+ revision="$(git rev-list --count $hash..HEAD).g$(git rev-parse --short HEAD)"
printf "%s.r%s" "$release" "$revision"
)
}