summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStefan Auditor2023-06-13 17:51:37 +0200
committerStefan Auditor2023-06-13 17:51:37 +0200
commit8c082d0cb8348eda753d0a8cfd18b44ecf3d7fc7 (patch)
tree53db3c5a0daab0d764845b1a1c966d859dd5fb80 /PKGBUILD
parent74102fe11e3aef524fb5e72c42d9d3d08d011560 (diff)
downloadaur-php-rdkafka.tar.gz
Fix code style and file names
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9cd387b5064c..4cc040e13db3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: Felix Golatofski <contact@xdfr.de>
# Contributor: 吕海涛 <aur@lvht.net>
-_pkgname=php-rdkafka
-pkgname=${_pkgname}
+_pkgname=rdkafka
+pkgname=php-${_pkgname}
pkgver=6.0.3
pkgrel=1
pkgdesc="AProduction-ready, stable Kafka client for PHP"
@@ -11,19 +11,19 @@ arch=("i686" "x86_64")
url="https://github.com/arnaud-lb/php-rdkafka"
license=('MIT')
depends=('php' 'librdkafka')
-source=("git+https://github.com/arnaud-lb/php-rdkafka")
-backup=("etc/php/conf.d/$_extname.ini")
+source=("${_pkgname}::git+https://github.com/arnaud-lb/php-rdkafka")
+backup=("etc/php/conf.d/${_pkgname}.ini")
md5sums=('SKIP')
build() {
- cd "$srcdir/$_pkgname"
+ cd "${srcdir}/${_pkgname}"
phpize
./configure
make all -j 5
}
package() {
- cd "$srcdir/$_pkgname"
+ cd "${srcdir}/${_pkgname}"
echo ";extension=${_pkgname}.so" > ${_pkgname}.ini
install -Dm644 ${_pkgname}.ini "${pkgdir}/etc/php/conf.d/${_pkgname}.ini"
make install INSTALL_ROOT="${pkgdir}/"