summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJohannes Schleifenbaum2014-12-30 10:50:45 +0100
committerJohannes Schleifenbaum2014-12-30 10:50:45 +0100
commit9394979fc68c002ce199bda7b554a8603fb9d9e7 (patch)
treee34dfe9daea8c16d39b94c63b2c0fdc921f310db /PKGBUILD
downloadaur-9394979fc68c002ce199bda7b554a8603fb9d9e7.tar.gz
all packages in aur subfolder
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..804ffa254ed0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Johannes Schleifenbaum <johannes [at] js-webcoding [dot] de>
+# Please report issues at https://github.com/jojosch/pkgbuilds
+
+_pkgbase=security-checker
+pkgname="php-${_pkgbase}"
+pkgver=2.0.0
+pkgrel=2
+pkgdesc="PHP frontend for security.sensiolabs.org"
+url="https://github.com/sensiolabs/security-checker"
+license="MIT"
+arch=("any")
+depends=("php>=5.3.3")
+makedepends=("php-box" "php-composer")
+install="${pkgname}.install"
+source=(
+ "https://github.com/sensiolabs/${_pkgbase}/archive/v${pkgver}.zip"
+)
+sha1sums=(
+ "53025de14d8b5c24fa5f971037fa32a5a74e34ea"
+)
+sha256sums=(
+ "472095084181484e4ea49b811dd51e8aac47b3593c48167a99f861e142af02da"
+)
+
+build() {
+ cd "${srcdir}/${_pkgbase}-${pkgver}"
+ composer install --prefer-dist
+ php-box build
+}
+
+package() {
+ cd "${srcdir}/${_pkgbase}-${pkgver}"
+ install -D -m644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -D -m755 "${_pkgbase}.phar" "${pkgdir}/usr/share/webapps/bin/${pkgname}.phar"
+ install -d "${pkgdir}/usr/bin"
+ ln -s "/usr/share/webapps/bin/${pkgname}.phar" "${pkgdir}/usr/bin/${pkgname}"
+}