summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNico Suarez2015-06-16 11:14:28 +0800
committerNico Suarez2015-06-16 11:14:28 +0800
commit7c61c9511e746eaee0d9c5f8e6f8d48ab0b3ed64 (patch)
treec655ad8f0fe8590500b4bf151693d2086b7c301f /PKGBUILD
downloadaur-7c61c9511e746eaee0d9c5f8e6f8d48ab0b3ed64.tar.gz
Migrated from old AUR
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7af2de6c7862
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+#!/bin/bash
+# Maintainer: Nico Suarez <nicodoggie@gmail.com>
+_pkgname=uprofiler
+pkgname=php-${_pkgname}-git
+pkgver=r117.483c1e5
+pkgrel=1
+pkgdesc="A passive hierarchichal profiler for PHP."
+arch=('i686' 'x86_64')
+url="https://github.com/FriendsOfPHP/uprofiler"
+license=('APACHE')
+provides=('php-uprofiler')
+makedepends=('make' 'git')
+depends=('php')
+
+source=("uprofiler::git://github.com/FriendsOfPHP/uprofiler.git" "uprofiler.ini")
+sha256sums=('SKIP'
+ '1a4ae4076cef64dd8412831fc5674831c26e8e6db6aec7a7244fde96a1d63fce')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${_pkgname}/extension" phpize
+ phpize
+ ./configure --with-php-config=/usr/bin/php-config --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/${_pkgname}/extension"
+ make INSTALL_ROOT="$pkgdir/" install
+ install -Dm644 "$srcdir/uprofiler.ini" "$pkgdir/etc/php/conf.d/uprofiler.ini"
+}