summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTom Richards2015-08-07 13:06:05 -0400
committerTom Richards2015-08-07 13:06:05 -0400
commitd91999945c54301066e7b40b02c752a0d2d36006 (patch)
tree1af2eb106cd64cd68e4af122aaa7fbc130e1b750 /PKGBUILD
downloadaur-d91999945c54301066e7b40b02c752a0d2d36006.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3df8c4785ac5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Tom Richards <tom@tomrichards.net>
+# https://github.com/t-richards/aur-vld
+_pkgname=vld
+_pkgver=VLD_0_13_0
+pkgname=php-vld
+pkgver=0.13.0
+pkgrel=1
+pkgdesc="The Vulcan Logic Dumper hooks into the Zend Engine and dumps all the opcodes (execution units) of a script."
+arch=('x86' 'x86_64')
+url="http://derickrethans.nl/projects.html#vld"
+license=('BSD')
+makedepends=('php')
+source=("https://github.com/derickr/vld/archive/VLD_0_13_0.tar.gz")
+sha256sums=('9b8eaac66309d4a869f17e72862baf90af13766ecf30975288a4bb1c944ed57a')
+
+build() {
+ cd "$_pkgname-$_pkgver"
+ phpize
+ ./configure
+ make
+}
+
+package() {
+ cd "$_pkgname-$_pkgver"
+
+ # PHP module
+ install -Dm755 modules/vld.so "$pkgdir/usr/lib/php/modules/vld.so"
+
+ # License
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}