aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSpencer Rinehart2014-08-01 11:41:29 -0400
committerSpencer Rinehart2015-06-10 12:54:25 -0500
commit497df0d2aea89556d578d00780c829e9a1823d9d (patch)
tree510aab55e2a2405ba776d5ca1e2531e3a91694bf /PKGBUILD
downloadaur-497df0d2aea89556d578d00780c829e9a1823d9d.tar.gz
Initial commit.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1f064523c2b4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Contributor: Spencer Rinehart <anubis@overthemonkey.com>
+
+_extname=wddx
+pkgname=("php-${_extname}")
+pkgver=5.6.6
+pkgrel=2
+pkgdesc="PHP extension for wddx"
+arch=('i686' 'x86_64')
+url='http://www.php.net/wddx'
+license=('PHP')
+depends=('php')
+backup=("etc/php/conf.d/${_extname}.ini")
+install="php-${_extname}.install"
+source=("http://www.php.net/distributions/php-${pkgver}.tar.gz")
+md5sums=('2baddcf979a0d4eb65434c4da3bd9cd3')
+
+build() {
+ cd "php-${pkgver}/ext/${_extname}"
+
+ phpize
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "php-${pkgver}/ext/${_extname}"
+
+ make INSTALL_ROOT="${pkgdir}" install
+ echo "extension=${_extname}.so" > "${_extname}.ini"
+ install -D -m644 "${_extname}.ini" "${pkgdir}/etc/php/conf.d/${_extname}.ini"
+}