summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorYour Name2021-03-11 17:21:58 +0100
committerYour Name2021-03-11 17:21:58 +0100
commit5dccce885bf1cb7bc9b69dcc01310423db7d033b (patch)
treebb8f9e8b0cc188c5998f9ba0622495669c3c228e /PKGBUILD
parent73d604c18b816893ac6d0a628bb5abf52b181c95 (diff)
downloadaur-5dccce885bf1cb7bc9b69dcc01310423db7d033b.tar.gz
latest version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 24 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e99b41aecc26..8291bcafc251 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,39 @@
# Maintainer: MartiMcFly <martimcfly [at] autorisation.de>
-# Last Version: curl -s 'https://oligarchy.co.uk/xapian/?C=M;O=D' | grep -oh '>[0-9]*\.[0-9]*\.[0-9]*\/<' | grep -oh '[0-9]*\.[0-9]*\.[0-9]*' | head -n 1
+# Last Version: curl -s 'https://oligarchy.co.uk/xapian/?C=M;O=D' | grep -oh '>[0-9]*\.[0-9]*\.[0-9]*\/<' | grep -oh '[0-9]*\.[0-9]*\.[0-9]*' | head -n 1
-pkgbase=php-xapian
-pkgname=('php-xapian')
-_realname=xapian-bindings
-pkgver=1.4.14
+pkgname=php-xapian
+pkgver="$(curl -s 'https://oligarchy.co.uk/xapian/?C=N;O=D' | grep -oh '>[0-9]*\.[0-9]*\.[0-9]*\/<' | grep -oh '[0-9]*\.[0-9]*\.[0-9]*' | head -n 1)"
epoch=1
pkgrel=2
pkgdesc="PHP bindings for Xapian"
-arch=('armv7h' 'i686' 'x86_64')
+arch=(
+ 'armv7h'
+ 'i686'
+ 'x86_64'
+ )
url="http://xapian.org/docs/bindings/php/"
-depends=('php' "xapian-core=$epoch:$pkgver")
-license=('GPL')
-source=("http://oligarchy.co.uk/xapian/${pkgver}/${_realname}-${pkgver}.tar.xz")
-sha512sums=('SKIP')
+depends=(
+ 'php7'
+ 'xapian-core'
+ )
+license=(
+ 'GPL'
+ )
-pkgver() {
- # Arch implements the latest release, for this reason the version has to be up to date!
- curl -s 'https://oligarchy.co.uk/xapian/?C=N;O=D' | grep -oh '>[0-9]*\.[0-9]*\.[0-9]*\/<' | grep -oh '[0-9]*\.[0-9]*\.[0-9]*' | head -n 1
-}
+_fileName="xapian-bindings-${pkgver}"
+source=("http://oligarchy.co.uk/xapian/${pkgver}/${_fileName}.tar.xz")
+sha512sums=('SKIP')
build() {
- cd "$srcdir/${_realname}-$pkgver"
- ./configure XAPIAN_CONFIG=/usr/bin/xapian-config \
- --prefix=/usr --with-php7
+ cd "${srcdir}/${_fileName}"
+ ./configure \
+ XAPIAN_CONFIG=/usr/bin/xapian-config \
+ --prefix=/usr \
+ --with-php7
make
}
package() {
- cd ${_realname}-$pkgver
+ cd ${srcdir}/${_fileName}
make DESTDIR="$pkgdir" install
}