summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFelix Yan2018-07-15 22:55:46 +0800
committerFelix Yan2018-07-15 22:55:54 +0800
commit5eee75bd28267cf21fcfb1c5a7f38644831dc42e (patch)
treef582ec37098bcc6ee7120297a73712d6866501a0 /PKGBUILD
parenta1fae6eefe396a4972c25788b83b4c9be43e6154 (diff)
downloadaur-5eee75bd28267cf21fcfb1c5a7f38644831dc42e.tar.gz
Fix source and enchant-2/icu compatibility
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ed7f495d97c8..d50d6af14921 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -28,7 +28,7 @@ pkgname=("${pkgbase}"
"${pkgbase}-xsl")
pkgver=5.3.29
_suhosinver=5.3.9-0.9.10
-pkgrel=8
+pkgrel=9
pkgdesc="A general-purpose scripting language that is especially suited to web development"
arch=('i686' 'x86_64')
license=('PHP')
@@ -39,7 +39,7 @@ makedepends=('apache' 'c-client' 'postgresql-libs' 'libldap' 'smtp-forwarder'
'curl' 'libxslt' 'openssl-1.0' 'db' 'gmp' 'systemd')
source=("http://php.net/distributions/${_pkgbase}-${pkgver}.tar.xz"
- "http://download.suhosin.org/suhosin-patch-${_suhosinver}.patch.gz"
+ "https://distfiles.macports.org/php5/suhosin-patch-${_suhosinver}.patch.gz"
'php.ini.patch' 'apache.conf' 'php-fpm.conf.in.patch'
'logrotate.d.php-fpm' 'php-fpm.service' 'php-fpm.tmpfiles'
'suhosin.patch'
@@ -116,6 +116,12 @@ prepare() {
# Allow php-tidy to compile with tidy-html5
sed 's/buffio\.h/tidybuffio\.h/' -i ext/tidy/tidy.c
+
+ msg "Enchant 2 fixes"
+ sed -i -e 's|include/enchant|include/enchant-2|' -e 's|-lenchant|-lenchant-2|' configure
+
+ msg "ICU fixes"
+ sed -i '/U_NAMESPACE_END/a using namespace icu;' ext/intl/msgformat/msgformat_helpers.cpp
}
build() {