summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFelix Yan2018-07-18 21:28:45 +0800
committerFelix Yan2018-07-18 21:28:45 +0800
commit636a85a431887f1b74e9b48040a58672608f842f (patch)
tree7477840c3b6fcec151ea2c6ea869fc6a0f59b8b1 /PKGBUILD
parent5eee75bd28267cf21fcfb1c5a7f38644831dc42e (diff)
downloadaur-636a85a431887f1b74e9b48040a58672608f842f.tar.gz
Patch the soname to make it co-exist with php56 and link successfully
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d50d6af14921..9d0c6a0f407a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -28,7 +28,7 @@ pkgname=("${pkgbase}"
"${pkgbase}-xsl")
pkgver=5.3.29
_suhosinver=5.3.9-0.9.10
-pkgrel=9
+pkgrel=10
pkgdesc="A general-purpose scripting language that is especially suited to web development"
arch=('i686' 'x86_64')
license=('PHP')
@@ -36,7 +36,7 @@ url='http://php.net'
makedepends=('apache' 'c-client' 'postgresql-libs' 'libldap' 'smtp-forwarder'
'sqlite' 'unixodbc' 'net-snmp' 'libzip' 'enchant' 'file' 'freetds'
'libmcrypt' 'tidyhtml' 'aspell' 'libltdl' 'libpng' 'libjpeg' 'freetype2' 'icu'
- 'curl' 'libxslt' 'openssl-1.0' 'db' 'gmp' 'systemd')
+ 'curl' 'libxslt' 'openssl-1.0' 'db' 'gmp' 'systemd' 'patchelf')
source=("http://php.net/distributions/${_pkgbase}-${pkgver}.tar.xz"
"https://distfiles.macports.org/php5/suhosin-patch-${_suhosinver}.patch.gz"
@@ -371,6 +371,7 @@ package_php53-embed() {
depends=("${pkgbase}")
provides=("${_pkgbase}-embed=$pkgver")
+ patchelf --set-soname libphp53.so ${srcdir}/build-embed/libs/libphp5.so
install -D -m755 ${srcdir}/build-embed/libs/libphp5.so ${pkgdir}/usr/lib/libphp53.so
install -D -m644 ${srcdir}/${_pkgbase}-${pkgver}/sapi/embed/php_embed.h ${pkgdir}/usr/include/${pkgbase}/sapi/embed/php_embed.h
}