summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEugene Lamskoy2023-02-21 14:38:50 +0200
committerEugene Lamskoy2023-02-21 14:38:50 +0200
commite74d0e8e4fdfb14f60dbd395dc102e6e9884d834 (patch)
treea3c90d50fa1461de3f94a8e4a1b1ed0a6fcd0e89 /PKGBUILD
parent44e5178cc4ba106adaed5b9659c9cc192f21d986 (diff)
downloadaur-e74d0e8e4fdfb14f60dbd395dc102e6e9884d834.tar.gz
dblib issues fixed. Openssl1.1 forced
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e0387a71a924..467ec2c5951f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,13 +16,14 @@
_phpbase="54"
_suffix=""
pkgver="5.4.45"
-pkgrel="6"
+pkgrel="8"
pkgbase="php54"
pkgdesc="PHP 5.4.45 compiled as to not conflict with mainline php"
_cppflags=" -DU_USING_ICU_NAMESPACE=1 -DOPENSSL_NO_SSL3=1 -DOPENSSL_NO_SSL2=1 -DU_DEFINE_FALSE_AND_TRUE=1 "
_build_apache_cfg="etc/httpd/conf/extra"
_build_bundled_gd="1"
_build_conf_d="etc/php54/conf.d"
+_build_forced_openssl_11="0"
_build_fpm_name="php-fpm54"
_build_fpm_service_name="php54-fpm"
_build_icu_src_dir="icu/source"
@@ -177,10 +178,9 @@ makedepends=(
"coreutils"
"findutils"
"libxslt"
- "openssl"
"e2fsprogs"
"openssl-1.0"
- "db"
+ "db5.3"
"postgresql-libs"
"unixodbc"
"libfbclient"
@@ -266,7 +266,7 @@ _ext_depends_mysql=(
)
_ext_depends_dba=(
"php54=5.4.45"
- "db"
+ "db5.3"
)
_ext_depends_odbc=(
"php54=5.4.45"
@@ -524,6 +524,10 @@ build() {
export EXTENSION_DIR="/usr/lib/${pkgbase}/modules"
if ((_build_openssl_v10_patch)); then
export PHP_OPENSSL_DIR="/usr/lib/openssl-1.0"
+ export PKG_CONFIG_PATH="/usr/lib/openssl-1.0/pkgconfig"
+ elif ((_build_forced_openssl_11)); then
+ export PHP_OPENSSL_DIR="/usr/lib/openssl-1.1"
+ export PKG_CONFIG_PATH="/usr/lib/openssl-1.1/pkgconfig"
fi
if [[ ! -z "${_cppflags}" ]]; then
CPPFLAGS+=" $_cppflags "
@@ -1558,5 +1562,5 @@ sha256sums=('e6b8530d747000eebb0089249ec70a3b14add7b501337046700544883f62b17b'
'c9b3c4153596b605a41456e8242d98e474be6391d6fb4b6ce70a21c4c23b5203'
'7e59ff3e1669d55f2a26ccdd748bfed6bbfd85d5d9206c1241cfd4443994f42c'
'616ec8aa12070fb058be511abdae703a62d1c99387dd6d2a7bb47cb1b5bbda5f'
- 'caf09b93feec38e4db644bfe4b4d7369b89df926f8041ed007f1cb6d2b687574'
+ '8febb003b694a82bc9e5af6c4daf947fbae58f909ffcccf3e908d07b51fea837'
'558e780e93dfa861a366c49b4d156d8fc43f17898f001ae6033ec63c33d5d41c')