summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJakob Gahde2016-07-29 22:11:59 +0200
committerJakob Gahde2016-07-29 22:11:59 +0200
commit8e36ab44774099ce28d5ebe7d0d8cfeb07d626b0 (patch)
tree9754cb62e63c9d8afe6d9dc3561b90a95c2ae896 /PKGBUILD
downloadaur-8e36ab44774099ce28d5ebe7d0d8cfeb07d626b0.tar.gz
php56-mailparse 2.1.6-1: New package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7f860d23e4dd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+
+pkgname=php56-mailparse
+pkgver=2.1.6
+pkgrel=1
+pkgdesc="A PHP extension for parsing and working with email messages"
+arch=('i686' 'x86_64')
+license=('PHP')
+url="https://php.net/mailparse"
+depends=('php56')
+source=("http://pecl.php.net/get/mailparse-${pkgver}.tgz")
+md5sums=('0f84e1da1d074a4915a9bcfe2319ce84')
+
+build() {
+ cd "${srcdir}/mailparse-${pkgver}"
+
+ phpize56
+ ./configure
+ make
+}
+
+package() {
+ cd "${srcdir}/mailparse-${pkgver}"
+
+ make install INSTALL_ROOT="${pkgdir}"
+}