summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFelix Yan2015-07-23 20:15:40 +0800
committerFelix Yan2015-07-23 20:15:40 +0800
commit2e43aae6022ccf9b86660423515bfa2b989e81e1 (patch)
treeb114bb17a952f4a00b6fc0761601eb7daa51ef04 /PKGBUILD
downloadaur-2e43aae6022ccf9b86660423515bfa2b989e81e1.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ee5908bc4691
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Pierre Schmitz <pierre@archlinux.de>
+
+pkgname=php53-xcache
+pkgver=3.2.0
+pkgrel=1
+arch=('i686' 'x86_64')
+pkgdesc='A PHP 5.3 opcode cacher'
+url='http://xcache.lighttpd.net/'
+depends=('php53')
+license=('custom')
+source=("http://xcache.lighttpd.net/pub/Releases/${pkgver}/xcache-${pkgver}.tar.bz2"
+ 'xcache.ini')
+backup=('etc/php/conf.d/xcache.ini')
+md5sums=('3655bd20483dc23d24f87f9dc924a62e'
+ '8fd9ce537ada9463c4b0c042243158c0')
+
+build() {
+ cd $srcdir/xcache-$pkgver
+ phpize
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd $srcdir/xcache-$pkgver
+ export NO_INTERACTION=1
+ make test
+ echo
+}
+
+package() {
+ cd $srcdir/xcache-$pkgver
+ make INSTALL_ROOT=$pkgdir install
+
+ install -Dm644 $srcdir/xcache.ini $pkgdir/etc/php/conf.d/xcache.ini
+
+ install -dm755 $pkgdir/usr/share/webapps/php53-xcache
+ cp -r htdocs/* $pkgdir/usr/share/webapps/php53-xcache/
+
+ install -Dm644 COPYING $pkgdir/usr/share/licenses/php53-xcache/COPYING
+}