summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHusam Bilal2023-01-26 02:12:39 +0300
committerHusam Bilal2023-01-26 02:12:39 +0300
commit68b04fb19d2d5830757765addecc65cc9ee903ac (patch)
treea47d8bb4cf839fe2a79feaadbe69a0a29997b931 /PKGBUILD
parent12931f236dcc3cb1fc3610f49fc1f91388dee0aa (diff)
downloadaur-php7-symlinks.tar.gz
Remove non-generic symlinks
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 7 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 00502920b70e..a46b1220eca5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,25 +5,20 @@ pkgver=1
pkgrel=1
pkgdesc='Symlinks PHP7 binaries and configuration without the "7" suffix'
arch=('any')
-depends=('php7')
+depends=('php74')
provides=('php')
conflicts=('php')
package() {
install -dm755 "$pkgdir/usr/bin/"
cd "$pkgdir/usr/bin/"
- ln -s php7 php
- ln -s php-fpm7 php-fpm
+ ln -s php74 php
+
+ install -dm755 "$pkgdir/usr/lib/"
+ cd "$pkgdir/usr/lib/"
+ ln -s php74 php
install -dm755 "$pkgdir/etc/"
cd "$pkgdir/etc/"
- ln -s php7 php
-
- install -dm755 "$pkgdir/usr/lib/systemd/system/"
- cd "$pkgdir/usr/lib/systemd/system/"
- ln -s php-fpm7.service php-fpm.service
-
- install -dm755 "$pkgdir/run/"
- cd "$pkgdir/run/"
- ln -s php-fpm7 php-fpm
+ ln -s php74 php
}