summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHusam Bilal2021-02-03 16:30:13 +0200
committerHusam Bilal2021-02-03 16:30:13 +0200
commit12931f236dcc3cb1fc3610f49fc1f91388dee0aa (patch)
tree756ad910541e7b11bdb52d314dc231f7f0d614c6 /PKGBUILD
downloadaur-12931f236dcc3cb1fc3610f49fc1f91388dee0aa.tar.gz
Initial
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..00502920b70e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Husam Bilal <me@husam.dev>
+
+pkgname=php7-symlinks
+pkgver=1
+pkgrel=1
+pkgdesc='Symlinks PHP7 binaries and configuration without the "7" suffix'
+arch=('any')
+depends=('php7')
+provides=('php')
+conflicts=('php')
+
+package() {
+ install -dm755 "$pkgdir/usr/bin/"
+ cd "$pkgdir/usr/bin/"
+ ln -s php7 php
+ ln -s php-fpm7 php-fpm
+
+ install -dm755 "$pkgdir/etc/"
+ cd "$pkgdir/etc/"
+ ln -s php7 php
+
+ install -dm755 "$pkgdir/usr/lib/systemd/system/"
+ cd "$pkgdir/usr/lib/systemd/system/"
+ ln -s php-fpm7.service php-fpm.service
+
+ install -dm755 "$pkgdir/run/"
+ cd "$pkgdir/run/"
+ ln -s php-fpm7 php-fpm
+}