summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWilliam Gathoye2018-05-14 15:58:38 +0200
committerWilliam Gathoye2018-05-14 15:58:38 +0200
commitfa5a0aace7223b9668fc473f490d004094ddf6fb (patch)
treef3213aff0dd194bc0435f970c10248484517acb0 /PKGBUILD
parent3c02c088d059ca8332e4e8ca2f4c68be3284b73a (diff)
downloadaur-fa5a0aace7223b9668fc473f490d004094ddf6fb.tar.gz
Avoid libphp clash with system lib in php-embed. WIP.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 11 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d6ba2da77aa8..c5c23ebf3f0d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -97,6 +97,17 @@ prepare() {
patch -p0 -i ${srcdir}/enchant-2.patch
patch -p1 -i ${srcdir}/php-icu-1100-Utilize-the-recommended-way-to-handle-the-icu-namespace.patch
patch -p1 -i ${srcdir}/php-icu-1101-Simplify-namespace-access.patch
+
+
+ # Build against specific libs in order to avoid clashes with official Arch Linux php package.
+ #sed -i configure -e "s/SAPI_SHARED=libs\/libphp7.so/SAPI_SHARED=libs\/lib${pkgbase}.so/g"
+ #sed -i configure -e 's/SAPI_SHARED=libs\/libphp$PHP_MAJOR_VERSION.$SHLIB_DL_SUFFIX_NAME/SAPI_SHARED=libs\/libphp$PHP_MAJOR_VERSION$PHP_MINOR_VERSION.$SHLIB_DL_SUFFIX_NAME/g'
+ #sed -i configure -e 's/OVERALL_TARGET=libphp$PHP_MAJOR_VERSION.la/OVERALL_TARGET=libphp$PHP_MAJOR_VERSION$PHP_MINOR_VERSION.la/g'
+ #sed -i configure -e 's/OVERALL_TARGET=libs\/libphp$PHP_MAJOR_VERSION.bundle/OVERALL_TARGET=libs\/libphp$PHP_MAJOR_VERSION$PHP_MINOR_VERSION.bundle/g'
+ #sed -i acinclude.m4 -e 's/OVERALL_TARGET=libphp\[\]$PHP_MAJOR_VERSION\[.la\]/OVERALL_TARGET=libphp\[\]$PHP_MAJOR_VERSION$PHP_MINOR_VERSION\[.la\]/g'
+ #sed -i aclocal.m4 -e 's/OVERALL_TARGET=libphp\[\]$PHP_MAJOR_VERSION\[.la\]/OVERALL_TARGET=libphp\[\]$PHP_MAJOR_VERSION$PHP_MINOR_VERSION\[.la\]/g'
+ #sed -i aclocal.m4 -e 's/OVERALL_TARGET=libs\/libphp\[\]$PHP_MAJOR_VERSION\[.bundle\]/OVERALL_TARGET=libs\/libphp\[\]$PHP_MAJOR_VERSION$PHP_MINOR_VERSION\[.bundle\]/g'
+
}