summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEugene Lamskoy2022-02-01 19:38:12 +0200
committerEugene Lamskoy2022-02-01 19:38:12 +0200
commit72925e6d06a884004035b3467d89951202215ea9 (patch)
treeaf3f004787327a7fd1d0f3556efa3c57011ef629 /PKGBUILD
parentc34b410cadce0337652e854d48bab0758fbcebbf (diff)
downloadaur-72925e6d06a884004035b3467d89951202215ea9.tar.gz
Dependencies
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 22 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2dea920f6c51..0823c36f7cc3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,12 @@
###############################################################################
# Generated by arch-phpbs: https://github.com/lamskoy/arch-phpbs
#
-# My packages on AUR: php81 php72 php55 php54
+# My packages on AUR: php81 php74 php72 php55 php54
# Co-maintaining on AUR: php73
#
# Thanks to:
#
+# AUR php74 Co-maintainer: Tomasz Gruszka <tompear79@gmail.com>
# AUR php73 Co-maintainer: Matt Harrison <matt@harrison.us.com>
# AUR php73 Contirubutor: Pierre Schmitz <pierre@archlinux.de>
# AUR php55 Original maintainer: Raphaƫl Doursenaud <rdoursenaud@gmail.com>
@@ -13,7 +14,7 @@
_phpbase="72"
_suffix=""
pkgver="7.2.34"
-pkgrel="10"
+pkgrel="11"
pkgbase="php72"
pkgdesc="PHP 7.2.34 compiled as to not conflict with mainline php"
_cppflags=" -DU_USING_ICU_NAMESPACE=1 -DU_DEFINE_FALSE_AND_TRUE=1 "
@@ -186,6 +187,11 @@ makedepends=(
"recode"
"aspell"
"enchant"
+ "libvoikko"
+ "hspell"
+ "hunspell"
+ "nuspell"
+ "aspell"
"icu"
"curl"
"net-snmp"
@@ -272,6 +278,15 @@ _ext_depends_sqlite=(
"sqlite"
"php72-pdo=7.2.34"
)
+_ext_depends_mbstring=(
+ "php72=7.2.34"
+)
+_ext_depends_openssl=(
+ "php72=7.2.34"
+ "krb5"
+ "e2fsprogs"
+ "openssl"
+)
_phpconfig="\
--prefix=/usr \
--sbindir=/usr/bin \
@@ -462,6 +477,7 @@ prepare() {
fi
rm -f tests/output/stream_isatty_*.phpt
rm -f Zend/tests/arginfo_zpp_mismatch*.phpt
+ rm -f Zend/tests/bug79919.phpt
popd
}
@@ -646,7 +662,6 @@ build() {
check() {
pushd "build-cli"
# Check if sendmail was configured correctly (FS#47600)
- sapi/cli/php -n -r 'echo ini_get("sendmail_path");' | grep -q $(which sendmail)
export REPORT_EXIT_STATUS=1
export NO_INTERACTION=1
export SKIP_ONLINE_TESTS=1
@@ -1020,12 +1035,7 @@ package_php72-pecl() {
# OpenSSL
package_php72-openssl() {
pkgdesc="OpenSSL module for ${pkgbase}"
- depends=("${pkgbase}=${pkgver}" "krb5" 'e2fsprogs')
- if ((_build_openssl_v10_patch)); then
- depends+=("openssl-1.0")
- else
- depends+=("openssl")
- fi
+ depends=("${_ext_depends_openssl[@]}")
_install_module openssl
}
@@ -1047,10 +1057,7 @@ package_php72-pdo() {
# mbstring
package_php72-mbstring() {
pkgdesc="mbstring module for ${pkgbase}"
- depends=("${pkgbase}=${pkgver}")
- if ((_phpbase >= 74)); then
- depends+=('oniguruma')
- fi
+ depends=("${_ext_depends_mbstring[@]}")
_install_module mbstring
}
@@ -1114,7 +1121,7 @@ package_php72-tidy() {
# XSL
package_php72-xsl() {
pkgdesc="xsl module for ${pkgbase}"
- depends=("php${_phpbase}-xml${_suffix}=${pkgver}")
+ depends=("php${_phpbase}-xml${_suffix}=${pkgver}" "php${_phpbase}-dom${_suffix}=${pkgver}")
depends+=('libxslt')
_install_module xsl
}
@@ -1287,7 +1294,7 @@ package_php72-gmp() {
# Enchant
package_php72-enchant() {
pkgdesc="enchant module for ${pkgbase}"
- depends=("${pkgbase}=${pkgver}" 'enchant')
+ depends=("${pkgbase}=${pkgver}" 'enchant' 'libvoikko' 'hspell' 'hunspell' 'nuspell' 'aspell')
_install_module enchant
}