summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEugene Lamskoy2022-02-01 19:37:24 +0200
committerEugene Lamskoy2022-02-01 19:37:24 +0200
commit6e7acc46b23cae5c714393ecc7455fabb83ec6b7 (patch)
tree17daa758ff6dcca9ad057f19b877ba259a6f7aa9 /PKGBUILD
parentd99a3e7fb15b38b3f2619fabd32d3dde6807923d (diff)
downloadaur-6e7acc46b23cae5c714393ecc7455fabb83ec6b7.tar.gz
Dependencies
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cf1380c17a1d..d675fca6294b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,7 +14,7 @@
_phpbase="74"
_suffix=""
pkgver="7.4.27"
-pkgrel="6"
+pkgrel="7"
pkgbase="php74"
pkgdesc="PHP 7.4.27 compiled as to not conflict with mainline php"
_cppflags=" -DU_USING_ICU_NAMESPACE=1 -DU_DEFINE_FALSE_AND_TRUE=1 "
@@ -177,6 +177,11 @@ makedepends=(
"oniguruma"
"aspell"
"enchant"
+ "libvoikko"
+ "hspell"
+ "hunspell"
+ "nuspell"
+ "aspell"
"icu"
"curl"
"net-snmp"
@@ -640,7 +645,6 @@ build() {
check() {
pushd "build-cli"
# Check if sendmail was configured correctly (FS#47600)
- #sapi/cli/php -n -r 'echo ini_get("sendmail_path");' | grep -q $(which sendmail)
export REPORT_EXIT_STATUS=1
export NO_INTERACTION=1
export SKIP_ONLINE_TESTS=1
@@ -1100,7 +1104,7 @@ package_php74-tidy() {
# XSL
package_php74-xsl() {
pkgdesc="xsl module for ${pkgbase}"
- depends=("php${_phpbase}-xml${_suffix}=${pkgver}")
+ depends=("php${_phpbase}-xml${_suffix}=${pkgver}" "php${_phpbase}-dom${_suffix}=${pkgver}")
depends+=('libxslt')
_install_module xsl
}
@@ -1273,7 +1277,7 @@ package_php74-gmp() {
# Enchant
package_php74-enchant() {
pkgdesc="enchant module for ${pkgbase}"
- depends=("${pkgbase}=${pkgver}" 'enchant')
+ depends=("${pkgbase}=${pkgver}" 'enchant' 'libvoikko' 'hspell' 'hunspell' 'nuspell' 'aspell')
_install_module enchant
}